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1.  Getting Started 
 

The following instructions tell you about minimum system requirements, how to 
install the Smart ID Software running Windows XP or later and start the program 
for the first time. 

 

 

System Requirements 

The recommended software and hardware configuration for your computer system to 
run the Smart ID Software is: 

 
 
· PC with a Pentium 4 or higher microprocessor. 
 
· 512 MB RAM. 
 
· Hard Disk with at least 100MB free disk space. 
 
. 20 KB per person 
 
· One CD-ROM 8X speed drive. 
 
· VGA or SVGA graphics adapter and monitor. 
 
. 800 x 600 Screen resolution 
 
· Mouse or other Windows-compatible pointing device. 
 
· Serial port. 
 
· Any ID card printer  

 

 
 
 
 
 



Installation 
 
Microsoft Windows XP or later is required to install and run the Smart ID Software. You 
can run the Smart ID Software on any system that can run Windows Vista, if the system 
has enough RAM and hard disk space. If Windows Vista is not installed, run 
the setup program for Windows before trying to install the Smart ID Software. 
 
 
Running Setup on Windows XP or Later: 

 
Insert the Card Software CD-ROM in your CD-ROM drive. The Smart ID Software Setup 
Screen appears after a few moments. If the Card Software Setup Screen does not show 
up automatically then go to CD-ROM drive and double click the Setup icon and follow 
the Setup instructions.   
                                                   

    
  

  
 

Note: 
In case your system is unable to locate Dongle driver during software installation. Then 
you need to run and install it manually by clicking C:\Program Files\Smart 
Solutions\Smart ID\Hardware\Install.exe 



2. Using the Smart ID Software 

 

Login Screen: 

 

             

 

 

 

To Login, please enter your username and password assigned by administrator. 

The default username is Admin and password is admin. 



The Main Smart ID Window 

 
The main Smart ID Software window, with its accompanying toolbars and menus, 
closely resembles the windows you work in for other Windows based programs. You will 
be working in the main window (and its sub-windows) as you design and print your 
cards. By default the application will be in design mode. 
 

 
 
 

The Rulers: 
 

Smart ID Software includes Rulers to help you align your artwork and arrange image 
elements symmetrically. Rulers are configured to display inches or centimeters. To 
display the rulers, choose Rulers from the View menu. To hide the rulers, choose 
Rulers from the View menu again. 
 
 
The Grid: 
 

A visible network of lines covering the card. As you draw objects, they will co-interact 
with the grid. You can turn it on and off using the Grid command from the View menu. 



Drawing Toolbar: 
 
The Drawing toolbar provide you with one-step access to lots of tasks. You can draw a 
rectangle, place a photograph, define a bar code, edit text and much more - all with just 
one click of a mouse button on one of Smart ID Drawing tools. 
 
 

The Status Bar: 
 

The Status Bar represents the cursor position within the card document. You can turn it 
on and off using the Status Bar command from the View menu. 
 
 
 

Creating Card Layout 

 
This section explains the procedures for opening existing card files, saving your work 
and creating the layout of a new card. 
 
 
Opening and Saving Card Files: 
 
You’ll find that opening and saving your card files are pretty much the same as in other 
Windows programs. 
 
To create a new card at any time, click the New button on the Standard toolbar. To 
quickly open one of the last cards you worked on, choose it from the list of recently used 
files at the bottom of the File menu. 
 
To open an existing card, click the Open button on the upper toolbar. When the Open 
dialog box appears, select the document in the File Name box, and then click OK. 
 
To save a card on disk, click the Save button on the Standard tool bar. When you save 
a card for the first time, the Card Software displays the Save As dialog box so that you 
can type a name for the card file. 

 
 
Card Properties: 
 
A card can be created in either portrait (print across the narrow side of the card) or 
landscape (print across the wide side of the card) orientation. The card defaults to 
landscape orientation. The card orientation can be changed at any time 



 
 
 
This above screen i.e. Card Properties will be prompted whenever you choose to create 
a New card by clicking New button on the standard toolbar or by selecting New from the 
File menu. 
 
To change the card properties of an already existing card, you just need to double click 
on the card layout or click the Properties button on the standard toolbar. 
 
In the Card Properties you can set card size, background colour, background image and 
transparency level options. 
 
 
 
Adding a Line: 
 

 To add a horizontal or vertical line 
 
1.  On the Drawing toolbar, click the Line tool; the pointer changes to a hand with 

the Line icon. 
2.  Move the pointer to the point on the card where you want to place one end of the 

line. 
3.  Press and hold the left mouse button and drag in a horizontal or vertical 

direction. As you drag, a line is drawn, with one end fixed where you began to 
drag, and the other end following the pointer. Continue dragging until the line is 
the desired length. 

4.  Release the mouse button. The line appears on the card. 



Adding a Rectangle: 
 

 To add a rectangle 
 

1.  On the Drawing toolbar, click the Rectangle tool; the pointer changes to a hand 
with the Rectangle icon. 

2.  Move the pointer to the point on the card where you want to place the upper left 
corner of the rectangle. 

3.  Press and hold the left mouse button and drag in any direction. As you drag, a 
rectangle forms with one corner fixed where you began to drag, and the other 
corner following the pointer. Continue dragging until the  

4.  Release the mouse button. The rectangle appears on the card. 
 
 
 
Adding Text: 
 

 To add text 
 
1.  On the Drawing toolbar, click the Text tool; the pointer changes to a hand with 

pen icon. 
2.  Move the pointer to the point on the card where you want to place a corner. 
3.  Press and hold the left mouse button and drag in any direction. As you drag, a 

rectangle forms with one corner fixed where you began to drag, and the other 
corner following the pointer. Continue dragging until the rectangle is the desired 
size. 

4.  Release the mouse button and double click the text rectangle, the Text 
Properties dialog box appears. 

  

 



5. Type some text into the box, for example: “Text 1”. 
6. You can also bound text field to today’s date or database field by clicking bound 

radio button and selecting appropriate field from the drop down list. 
7.  Click OK to complete the action. 
 
 
 
Adding an Image: 
 

 To add an Image to the card 
 

1.  On the Drawing toolbar, click the Image tool; the pointer changes to a hand with 
the rectangle icon. 

2.  Move the pointer to the point on the card where you want to place the upper left 
corner of the image. 

3.  Press and hold the left mouse button and drag in any direction. As you drag, a 
rectangle forms with one corner fixed where you began to drag, and the other 
corner following the pointer. Continue dragging until the rectangle is the desired 
size. 

4.  Release the mouse button and double click the rectangle, Image Properties 
dialog box appears. 

 

            



5. In Load from File tab, browse   a photograph, fingerprint or signature (or 
other artwork) to your card from an image file. 

6. You can also add an image that is not in a file by using a camera, scanner or 
others. First select the desired Source from the list by clicking  and then click 

the Capture  button to capture the image. 

7. By Clicking , you can enhance and edit the selected image properties. Using 
‘Cut Out Color’ property you can remove the chosen color in the background 

 
 

             
 
 
8. In Dynamic Image tab using ODBC, you can Bound an image object to 

database by selecting an appropriate field name from the drop down list.  
 

            
 



8.  Also you can point database field to an Image Folder on your hard drive.  
9.  Finally Click OK to complete the action. 
 
 
Note: Smart ID supports ‘SecuGen Hamster IV’ for fingerprint and ‘TOPAZ SigLite 

LCD 1x5 USB’ for signature capturing. To capture fingerprint or signature on to 
the card using those listed devices, you need to select the source by clicking  
button  

 

              
 
Then select either Fingerprint or Signature from the Image Source list and hit OK 
button. 
 
 

Now by clicking  button, the capturing window will appear,  
 

    
 
      Place your finger on the SecuGen device              Sign on the Topaz SigLite device  

 
 
Finally hit the OK button to save the captured image on the card 
 
 
 



Adding a Bar Code: 
 

 To add a bar code to the card 
 
1.  On the Drawing toolbar, click the Bar Code tool; the pointer changes to a hand 

with the pen icon. 
2.  Move the pointer to a place on the card where you want to place a corner of the 

bar code. 
3.  Press and hold the left mouse button and drag in any direction. As you drag, a 

rectangle forms, with one corner fixed where you began to drag. The other 
corner follows the pointer. Continue dragging until the rectangle is the desired 
size. 

4.  Release the mouse button and double click the bar code rectangle, Bar code 
Properties dialog box appears. 

 

            

 
5.  Select a bar code Format from the list. You can choose from among the 24 

styles. 
6.  Type the data you want to appear in the bar code. 
 
7.  Click OK. The bar code will appear on the card. 
 
 
 
 
 
 
 
 
 



Bar Code Standards 
 

The number of elements and their order is defined by the bar code standard used. 
There are many bar code standards to choose from and each standard was developed 
for the specific data requirements of various industries. Each standard dictates the 
maximum number of characters a symbol can represent, as well as what kind of data is 
represented. 
 
Consequently, the number of characters in the information field and the type of 
information represented will play a role in which bar code standard can be used. Other 
considerations include what standard(s) trading partners use, the scanning environment 
(type of scanner, printable area, symbol durability, etc.) and the symbol printing 
requirements. 
 
 

Symbologies 
 

Symbology is the term used to describe the rules specifying the way data is encoded 
into the elements (bar and space widths) that comprise a bar code standard. 
 
 
Smart ID Software Symbologies 
 

The symbologies listed below can be printed with the Card Software. 
 
 
Summary of Supported Bar Codes 
 

 
           U- Upper Case, L - Lower Case, D - Digits, C - Control Characters 



Adding 2D Bar Codes: 
 

 To add 2D bar code to the card 
 
1.  On the Drawing toolbar, click the 2D Bar Code tool; the pointer changes to a 

hand with the pen icon. 
2.  Move the pointer to a place on the card where you want to place a corner of the 

bar code. 
3.  Press and hold the left mouse button and drag in any direction. As you drag, a 

rectangle forms, with one corner fixed where you began to drag. The other 
corner follows the pointer. Continue dragging until the rectangle is the desired 
size. 

4.  Release the mouse button and double click the bar code rectangle, Bar code 
Properties dialog box appears. 

 

           
 

Note: There are three different types of 2D Bar Codes available in Smart ID i.e. 
QR Code, PDF417 and DataMatrix 

 
5.  Select a bar code type from the list 
6.  Type or bound the data you want to appear in the bar code. Set the appropriate 

parameters associated with each bar code type 
7.  Click OK. The bar code will appear on the card. 
 
 



Working with Objects 

 
This part explains how to work with objects. 

 
 
Aligning Objects: 
 
Use the Align Tool in Object Menu to align multiple selections of objects on the card. 
The selected objects will be aligned with the dominant object. 
 
The available alignments are: 
 
Align Left - Aligns the selection to the left. 
Align Horizontally Center - Centers the selection horizontally. 
Align Right - Aligns the selection to the right. 
Align Top - Aligns the selection to the Top. 
Align Vertically Center - Centers the selection vertically. 
Align Bottom - Aligns the selection to the bottom 
 

 

 
Sizing Objects: 
 
Use the Size Tool in Object menu to resize multiple selections of objects on the card.  
 
To Tallest – Resize the selected objects to the tallest 
To Shortest – Resize the selection to the shortest 
To Widest – Resize the selection to the widest 
To Narrowest – Resize the selection to the narrowest 
 

 

Moving Objects: 
 
You can draw objects in any order and then move them up and down as needed. 
 
1.  Select the objects you want to move up or down in the stack. 
2.  Either use the toolbar on the main window or In Object menu, select Move and 

then click Bring to Front or the Send to Back option. 
3.  The selected object will be placed at the front or the back of the stack. 
 
 
 
 
 
 



Configuring Database 
 
The Smart ID Software accesses databases through ODBC drivers.  
 
ODBC was created as a way of setting a standard to access data on files. Using 
concepts like layers and layer abstraction, it allows the user to access data on his hard 
disk, in a local network or even in a Wide Area Network, using desktop or server/client 
specifications, in any database format that have available ODBC driver. 
 
External Data Sources can be configured by the user running the ODBC administrator 
to gain access to the files. 
 
To run ODBC manager, go to View menu, click Connections and then ODBC 
Manager. Now add and configure the User DSN that points to the data source. 
 
 

 
 

After configuring data source successfully, select one of the sources from the window 
below and click Next.  
 
 



 
 
 
The Table view window below appears, showing tables in a database 
 

 
 
 
 
 



Working with Tables 
 
 
Add a new Table: 
 
After connecting successfully to the database. In Table view window, click New Table 
button, the dialog box below appears 
 
 

 
 
Here you can add a new table to an existing database. 
 
Enter Table Name, Column or Field Name and Data Type and hit the Add button. You 
can also remove the added table by clicking Remove button.  
 
Finally click the Finish button 
 
 
 
 
 
 
 



Modify an existing Table: 
 
In Table view window if you want to modify an existing table just select that table and 
click Modify Table button.  
 
The following window will be displayed. 
 

 
. 
 
Here you can Add, Modify and Remove the data fields. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Remove a Table: 
 
Select the table from the list that you want to be removed and click the Remove Button 
 

          
 

                    

We already learnt how to configure data source and work with tables in a database. 
Now the next step is to display the contents of a database in our main application so 
that we can attach cardholder records to the card template for printing purposes. 

To do that, just follow the instruction below 

Select the table from the list and click next 

  



Now select the fields that you want to attach to the cardholder details from ‘Available 
Fields’ column and then click arrow > to move them to the next ‘Selected Fields’ 

Column. 

 

On hitting finish button, the following screen will be displayed, 

 



Card Template Design 

The Card Design Mode is where you create templates for cards, either from scratch or 
by modifying existing templates. It is here that you decide what your cards will look like, 
what types of text and data they will hold and display, and what types of special features 
(such as barcodes, magnetic stripes or chips) they will incorporate. This is all done 
through a simple drag-and-drop visual interface, while Smart ID takes care of creating a 
custom database for you ‘behind the scenes’. The best part is that no database 
programming knowledge or skills is needed. To fully appreciate the powerful features of 
the Card Design Mode, take a look at the simple steps involved with creating a new 
card template. 

To create a new card template, press the ‘New’ button on the upper left of the main 
window. 

After pressing the ‘New’ button, a ‘Card Properties Options’ window will appear asking 
you to specify Card Properties. 

 

After you select the basic properties, a new blank template appears within the workspace. 



 

 
 

Note:  If you are still in Data Mode, Click on the  Design Mode/Data Mode button 
right above the list of records and start designing the templates based on your 
requirements.  
 
If you want to attach cardholder records to the card template then always bound the 
Text and Image objects on the card template with the database record fields. 
 
 
Now start designing a card according to your requirements. 
 
 
 
 
 
 
 
 
 
 



 
A new card template with Text and Photo fields bounded to a database will look like this 
window below. 
 
 

 

 

 

 

 

 



Now on main window if you switch to Data mode  and select a record from the list 
then that selected record in the database will appear on the card template. Have a look 
at the screen below. 

 

 

 

 

 



Cardholder Records 

 
Data Mode is the part of Smart ID that you will use most often. This is where the 
individual cardholder’s photograph, signature, biometric and personal data can be 
captured and added to the card template’s database. The Data mode is very simple to 
use.  
 
Let’s take a look at how the Data Mode functions by opening the card template we 
created in the last section, and then adding records to the database.  
 
 

 Adding a Record: 
 
Enter user details in the text boxes. 
 
To capture image in photo box, first you need to click select the source by clicking 

downwards arrow on  button and select device from the list. A device could be a 

camera or scanner that supports Twain or Direct Show. For capturing hit the  button 
again. 
 

You can also browse image from your hard drive by clicking  button.  
 

 



Smart ID supports ‘SecuGen Hamster IV’ for fingerprint capturing. To capture fingerprint 

using SecuGen device, you just need to click , place your finger on the SecuGen 
scanner and get the fingerprint captured automatically.  
 

             
 
 
Smart ID also supports ‘Topaz SigLite LCD 1x5 USB’ for signature capturing. To 

capture signature using Topaz device, you just need to click , sign your signature on 
the Topaz  signature pad and get the fingerprint captured automatically.  
 

             
 
 
Finally hit the OK button to save all the information into the database. 
 
 
 
 
 
 
 
 
 



 Editing a Record: 
 
Double click the record or select it and click the edit icon placed just above the records 
list. Now you can edit any of the required text or image fields. 
 
 

 
 
 
 



Existing image can be edited by clicking  button. In editing window you can adjust 
the image properties  
 

 
 
 
Note: Image cropping can be done by marking the ‘Crop’ checkbox. Also you can 
remove selected background color from an image by marking the ‘Cut Out Color’ 
checkbox property. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 Deleting a Record: 
 

Select the record from the list and click the delete button located just above the 
record list. 
 

 
 
 
The system will ask you for delete action confirmation. 
 

          
 
 



 

Query Editor  
 

The query editor allows the user to Select and Find records on the Database. 

When you select Query Editor from the Tools menu. A dialogue box will be displayed 
as shown below. 

 

 

 

 

Select a Database Field from drop down list box, select operator, next to it enter the 
value in your query and press "Run" button to get a smaller list of records.  

 

Note: You can also save the query by hitting the “Save” button. When required you can           
run the saved query to get the desired list of records. 

 

 

 

 

 

 

 

 

 

 



Data Encoding (Mag. Stripe Cards) 
 
If your printer is equipped with a magnetic stripe encoder, you can encode data onto 
cards that have an embedded magnetic stripe. 
 
There are two kinds of magnetic stripe cards: low coercivity and high coercivity. 
There are three magnetic tracks on a magnetic stripe card. To comply with 
international standards, each track is limited to a certain number and type of 
character. 
 
The following table lists the number and type of characters allowed on each of the 
three tracks. 

  
Track 

  

Character Limit 

  

Allowed Characters 

  
1 79 alphanumeric ASSCII codes 32-95 Field 

Separator is ^ 

 
2 40 numeric ASCII ASSCII codes 48-63 Field 

Separator is = 

 
3 107 numeric ASCII  Separator is ^ 

 
 
 
Selecting Encoder: 
 
To associate the encoder type with the printer, select Printer Encoder Setup from the 
Tools menu.  
 

 



Select the desired printer from the drop down menu and then assign encoder from the 
list below. Finally hit the OK button to save the printer and encoder association.  
 
 

Data to Encode: 
 
In the Tool menu, select Magnetic Encoding. 
 

 
 
 
Enter data in Track1, Track2 and Track3. You can also bind the Track data to the 
connected database. Click OK button to save the data. 
 
Finally to transfer encoded data on to the Mag Stripe cards, select Print from the File 
menu. 
 

 
 
 
Then select Magnetic Encode from the Print dialog box and hit the print button. This 
will encode data on to the magnetic stripe card using your printer encoder. 
 
 



Net Licence: 
 
How to use the Net Licence; please follow the following steps below 
 
 

1. Install Master software from the CD and plug in the Master USB dongle in to the 
computer. 
 

2. Run the Smart ID software, connect the database using DSN, design the card 
and save the design template on to your hard drive. 

 
3. Now install the Client version of Smart ID software from the CD in your Client PC 

and put Net USB licence dongle in to the Client PC. 
 

4. Make a DSN in Client PC and point it to the central database. Please make sure 
you use exactly the same name for DSN as the one you’ve used it in Master PC 
for creating DSN. 
 

5. Now copy the saved template from Master PC to the Client PC and double click 
the template to run. 
 

Note: You can only print in Client PC using the Net licence 
 
 
 


