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Section 1

1 Getting started
The Asure ID® User Guide covers the basics of the Asure ID user interface, installation, and configuration. For 
a more in-depth explanation of Asure ID, see the Asure ID Reference Guide (PLT-01797). This reference guide 
can be downloaded from the HID Global® web site http://www.hidglobal.com/documents. 

1.1 Supported OS and database engines
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Supported Operating Systems

Windows 7 (32-bit and 64-bit)
Windows 8 (32-bit and 64-bit) 
including Windows 8 Pro Tablets
Windows 10 (32-bit and 64-bit)

All Asure ID Editions

Supported Database Engines

Microsoft Access (2000 and 
2002/2003)

Native Native, 
Live Link

Native, 
Live Link

Native, 
Live Link

Native

SQL Server (2000, 2005, 2008, 
2012, 2014, 2016, and 2017)

Native, 
Live Link

Native, 
Live Link

Native

Networkable1

1. Asure ID site license enable sharing of networked database information on multiple workstations.

X X

MySQL (version 5) Live Link

Oracle (9i and 11g) Native,
Live Link

Native

Microsoft Active Directory / LDAP Live Link

ODBC Live Link
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1.2 System requirements
1 GHz or faster processor

1 GB RAM

1 GB available hard disk space

Supported operating systems

1.3 Installation
The Asure ID installation files can be accessed in either of the following:

The Asure ID CD. Insert the CD into the PC and follow the instructions. 

Note: If the CD does not run automatically, browse to the Setup.exe file.

Download the software from the HID Global web page, www.hidglobal.com/AsureID.

1.3.1 Installation wizard
1. The Installation Wizard opens and starts the installation.

2. Select a language from the pull-down list, and click Next.

Note: To install the software in Indonesian you download/install the English version of Asure ID, then 
use the Change Language option to change the program to Indonesian. See Section 2 The 
Options window. 

3. Read and accept the License Agreement, and click Next.

4. Select a folder to install the software, and click Next.

5. When installation is complete, Set the Installation Options:

Activate Asure ID – With a license key you can activate the Asure ID software. If this option is not 
selected, Asure ID is installed with a 30-day trial license. See Section 1.3.2 Activate Asure ID.

Configure Native Data Source – Allows you to configure the native data source which stores card 
templates and Asure ID system information. By default Asure ID sets the native source to an 
embedded Microsoft Access data source.

Note: This option is recommended for installations where Asure ID is used on multiple PCs, where all 
template and reporting information needs to be consistent.

Automatically Check for Updates – Notifies you of product updates.
8 September 2018

http://www.hidglobal.com/products/software/asure-id


PLT-01485, Rev. 2.5 Getting started
6. Click Finish.
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1.3.2 Activate Asure ID
If Activate Asure ID is selected, Asure ID prompts you to enter the following information and the license key. 

Note: The license key is located on the back of the CD case. 

1. Click Phone Activation or Activate Online. 

Note: Online activation requires an Internet connection.

2. Click OK.

Note: If Phone Activation is selected, you are directed to call a provided number and provide this 
information to HID Global.

Printer Model

AANNN-AAAANANA
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1.4 Initial login
1. Open Asure ID by double-clicking the Asure ID icon.

Note: If the software has not been activated the Activation Required window opens. Select a version of 
Asure ID. Click Activate. For a 30 day trial version, click Continue.

2. For Asure ID Express editions and above, enter:

User ID: admin 
Password: admin 

Note: Asure ID Solo users are not required to enter a user ID or password.

Note: To identify the Asure ID edition purchased, see the Licensing window (File > Options > 
Licensing). The edition is displayed under the Asure ID section with the license key.

3. You can modify the Starting Application option if needed. 

4. Click OK.
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1.5 Window layout of Asure ID
With each Application that is selected there is a corresponding set of tabs, tools and display screens. Each of 
these Application windows are described in detail in the following sections.

Applications: This side panel contains all the applications modules used to design, create and manage 
security issuance cards. See Section 1.5.1 Asure ID application modules.

Card Properties: When accessed, the data fields of the cards (Data Field tab) as well as Smart Chip 
Applications (iDIRECTOR tab) are displayed.

Current Cursor Location: The X/Y coordinates show the current position of the cursor. If rulers are displayed, 
the markers also show this position.

Card View & Zoom Controls

Card View: You can toggle between showing both sides of the card and either front or back. These 
views are only enabled if the card is dual-sided.

Zoom Controls: You can zoom in and out as well as set specific zoom levels.

Current Cursor
Location

Card View &
Zoom Control

A
p

p
lic
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ro
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Card Template
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1.5.1 Asure ID application modules

1.5.1.1  Home
Card Design enables you to create a card template for each card type (for example, employee card, 
contractor or student). 

Data Entry allows you to add, modify, and delete card records, including acquiring photos and printing 
cards.

Reports allows you to view standard reports (for example, user activity and template activity reports) 
and custom reports.

1.5.1.2  iCLASS SE encoder
The iCLASS SE Encoder application allows you to create work instructions and embed them into a template.

Work Order Manager

Key Management

Reader Configuration

1.5.1.3  Advanced
User Config - Allows you to manage user privileges and login credentials for Asure ID Editions of 
Express and above.

Laser Config - Allows configuration of numerous laser settings.

Note: With the Asure ID internal database, you can store card templates and cardholder information.

Note: With Live Link, you can also print card data from external databases such as HR, security or ERP. The 
Live Link wizard sets up real time data exchanges with a few mouse clicks. At print time, Live Link 
accesses and delivers the data that populates the external data fields on each card. For detailed 
information on the Live Link, see the Asure ID Reference Guide (PLT-01797).
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Section 2

2 The Options window
The Options window is available on every File tab, and allows you to manage the iCLASS SE® Encoder 
Formats, Plugins, Database, Options, and User Options.
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2.1 Configurable options
The Options window has the following configurable sections. For detailed information on each option, see the 
Asure ID Reference Guide (PLT-01797).

Language: Allows you to set the default language of the application.

Template: Allows you to set the basic template options for the Asure ID application.

Skins: Allows you to customize the look of the Asure ID application by selecting a predefined skin.

Resources: Allows you to access resource information for the application.

Printing: Allows you to define all of the printing options for the application.

Advanced Printing: This option is used to configure the printer chip encoding and magnetic encoding 
command sequences. The parameters auto-fill for the selected printer.

Encoding: Allows you to manage all the encoding settings within the printer.

Note: There is a desktop encoder available, that allows you to encode cards with a separate device.

Licensing: Allows you to view, modify, and activate the licensing information of the Asure ID 
application. 

Card Design: Allows you to set the Card Design default settings for the text labeling, field formatting 
and compound field formatting.

Devices: Allows you to select from available Photo and signature devices.

iCLASS SE Encoder: Allows you to modify iCLASS SE Encoder options on the Asure ID application. 

Note: This option has multiple tabs; Format, Plugins, Database, Options, and About.
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Section 3

3 Card Design application
The Asure ID Card Design application allows you to:

Lay out and design a card template.

Add technologies, including a barcode.

Personalize the work environment, including adding and removing grid lines and rulers as well as 
modifying the card view, orientation, zoom level and properties.

Link data fields to external data sources.

Save, edit and export work.

The Card Design application is used to create the card layout for printing and encoding. Each card layout is 
saved as a template for use by the Data Entry application.

Important: After the template is saved with the links to the data source, you cannot add additional fields. 
The existing fields can be modified, but if a new field is needed, a new template needs to be 
created. 

For detailed information on the Card Design application, see the Asure ID Reference Guide (PLT-01797).
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3.1 Card Design overview
The Card Design application has the following tabs, with a corresponding toolbar.

File: This tab allows you to perform template operations.

Home: This tab contains all the tools to create/modify a card template.

Card Setup: This tab displays the current card layout, and additional tools for card configuration.

View: This tab allows you to display and modify the current view.

3.2 Basic Card Design tutorial
The tutorial walks through the process of creating a basic ID card. From this example, you should be able to 
create their own templates, import data, and print cards.

The basic Card Design is as follows:

Section 3.2.1 Create a template

Section 3.2.2 Add a text label (company name)

Section 3.2.3 Add a data field (employee number) 

Section 3.2.5 Compound field (last name, first name)

Section 3.2.6 Add a photo 

Section 3.2.8 Add image (logo)

Section 3.2.7 Add a signature

Additional capabilities, such as magstripes, barcodes and Smart Chips are covered in Section 3.3 Advanced 
card design tutorial.
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3.2.1 Create a template
Note: For detailed information on Card Design see the Asure ID Reference Guide (PLT-01797).

1. Select Card Design applications > File tab > New Template. 
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2. Select Create New Template. 

Note: Selections are indicated with an orange background and selected options are displayed in the 
Card Properties pane.

3. The window displays each step to create a new template. Set the following options:

Note: The selected options are displayed in the Card Properties pane.

4. Click OK. The new template opens in the display window.

Field Setting

Select Card Size and Number of Sides Single Sided CR-80

Select Card Orientation Landscape

Select Magstripe Properties None

Select Technologies None
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5. Select File tab > Save Template. Enter a Name for the template and click OK.

6. The template name displays on the top of the window, and the card information and view controls are 
at the bottom of the window.

Note: You can adjust the view displayed from the View tab options. 
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3.2.2 Add a text label (company name)
A text label prints the same on every card. There is no data entry or database that feeds into this field. For 
this example a Company Name is added.

1. Select Card Design application > Home tab > Text Label. 

2. Click in the Card Display pane to open Text Properties and set the following:

Field Setting

Text Label Define the field name and enter the text to display in this field. 
Note: The Field Name should be a name that can be associated to the actual field text. 

Field Name: Enter Company Name
Field Text: Enter your company name (example is HID Global).

Font Set the font options. In this example the following was set:
Font Name: Arial Black 
Color: Black
Font Height: 14
Font Style: No selection was made.

Alignment Select alignment options. In this example both options were set as Center.

Options Select the following options as needed. In this example Auto Size is selected.
Word Wrap
Laser Engrave
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3. Click OK and Save (File tab > Save Template). 

3.2.3 Add a data field (employee number)
The data field adds a unique data field to the card record (i.e. employee number). See Section 4 Data Entry 
application for information on populating the Data field.

1. Select Card Design application > Home tab > Data Field. 

Placement Enter a specific location for the label. The text box can be moved using drag/drop.

Printing Select the following options as needed. In this example no options were selected.
Non-Printable Entry, Conditional, and Print on Fluorescing Panel

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
Fill Color: Transparent

Field Setting
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2. Click in the Card Display pane to open Data Field Properties, set the following:

Field Setting

Data Field Define the field name and enter the text to display in this field. 
Note: The Field Name should be a name that can be associated to the actual field text. 

Field Name: Enter Employee Number
Field Type: Text
Field Options: This is a Mandatory Field

Font Set the font options. In this example the following was set:
Font Name: Arial 
Color: Black
Font Height: 10
Font Style: No selection was made.

Alignment Select alignment options. In this example Both options were set as Center.

Options Select the following options as needed. In this example the option Reduce to Fit is 
selected.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Select the following options as needed. In this example no options were selected.
Non-Printable Entry, Conditional, and Print on Fluorescing Panel

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
Fill Color: Transparent
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3. Click Advanced Data Field Options. 

Note: The Advanced Data Field Options window shown below is for a Data Field that has the Field 
Type of Text selected. For information on other Field Types Advanced Data Field Options, see 
the Asure ID Reference Guide Section 3 Card Design Application (PLT-01797). 

4. Set the following:

5. Click OK to close the window.

6. Click OK to close the Data Field Properties window. 

Field Setting

Text Options Set the following Text Options: 
Default Value: Enter a default value (in this example we entered HID Global - ). This 
displays on all cards prior to any data entered during Data Entry. 

Note: This field is not required.
Max Characters: 20
Min Characters: 0
Format: None

Data Source Source: Data Entry

Picklist No options selected.

Data Formatting No options selected.

Data Entry Options No options selected.
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7. The newly created Data Field can be positioned on the card, by simply selecting and dragging.

8. Select File tab > Save Template.
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3.2.4 Add a data field picklist (employee dept.)
The Data Field Picklist allows you to select a requirement from a list. See Section 4 Data Entry application for 
information on populating the Data field.

1. Select Card Design application > Home tab > Data Field.

2. Click in the Card Display pane to open Data Field Properties, set the following:

Field Setting

Data Field Define the field name and enter the text to display in this field. 
Note: The Field Name should be a name that can be associated to the actual field text. 

Field Name: Enter Employee Dept.
Field Type: Text
Field Options: Do not select any options.

Font Set the font options. In this example the following is set:
Font Name: Arial 
Color: Black
Font Height: 10
Font Style: No selection was made.

Alignment Select alignment options. In this example Both options are set as Center.

Options Select the Reduce to Fit option.
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3. Click Advanced Data Field Options. 

Note: The Advanced Data Field Options window shown below is for a Data Field that has the Field Type 
of Text selected. For information on other Field Types Advanced Data Field Options, see the 
Asure ID Reference Guide, Section 3 Card Design Application (PLT-01797) .

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Do not select any options.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
Fill Color: Transparent

Field Setting
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4. Set the following:

Note: Set the Picklist options first, to enable the correct Default Value field.

5. Select the Manage the Picklist link.

6. Click Add an Item. 

7. Enter Human Resources into the field, and click OK.

8. Repeat this process entering Engineering and Finance to the picklist.

9. Click OK.

Field Setting

Text Options Set the following Text Options: 
Default Value:  <NULL>
Max Characters: 255
Min Characters: 0
Format: None

Data Source Source: Data Entry

Picklist Select the following options:
Use a picklist to select the value
Allow null picklist value

Data Formatting Do not select any options.

Data Entry Options Do not select any options.
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Note: These new items now appear in the drop-down menu for the Default Value field.

10.Click OK to close the Advanced Data Field Options window.

11. Click OK to close the Data Field Properties window

12. The picklist does not display in the Card Design Application.

13. Position the field on the card design area approximately where shown.

14. Select File tab > Save Template.
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3.2.5 Compound field (last name, first name)
A Compound Field is useful when multiple data fields are to be aligned next to each other. An example of 
using a Compound Field is placing a last name one space after the first name.

1. Select Card Design application > Home tab > Compound Field.

2. Click in the Card Display pane to open Compound Field Properties, set the following:

Field Setting

Compound 
Field

Define the field name and enter the text to display in this field. 
Note: The Field Name should be a name that can be associated to the actual field text. 

Field Name: Enter Full Name
Field Text: This field auto-populates after the data has been entered.

Actions Click Insert Data Field to add data to the field.
Click Insert Existing Data Field to use a existing data field set up on the card template. 

Font Set the font options. In this example the following was set:
Font Name: Arial
Color: Black
Font Height: 10
Font Style: No selection was made.

Alignment Select alignment options. In this example Both options were set as Center.

Options Select the Reduce to Fit option.
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3. Select Insert Data Field.

4. Set the following on the Data Field Properties window:

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Do not select any options.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
Fill Color: Transparent

Field Setting

Field Field Name: Enter First Name
Field Type: Text
Field Options: Do not select any options.

Text Options Set the following Text Options: 
Default Value:  Leave blank.
Max Characters: 255
Min Characters: 0
Format: None

Data Source Source: Data Entry. 
For information on adding a database source, see Section 4 Data Entry application.

Field Setting
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5. Click OK.

6. Repeat steps 3, 4, and 5 with the Field name entered as Last Name. 

7. Enter a space between the first and second data fields, on the Field Text display pane. If this is not 
done, when the data is entered the two text fields are continuous.

Picklist Do not select any options.

Data Formatting Do not select any options.

Data Entry Options Options disabled.

Field Setting
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8. Click OK. Position the field on the card design area approximately where shown.

9. Select File tab > Save Template.

3.2.6 Add a photo
The native database for Asure ID has a size limitation of 2GB when using Microsoft Access (MS Access 
limitation). Large photo files may cause the database to reach its limitation and prevent the addition of 
records. It is recommended to place photos in a folder, and using a photo field in the template.

1. Select Card Design application > Home tab > Photo.
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2. Click in the Card Display pane to open Photo Properties, set the following:

3. Click OK.

4. Position and size the photo field on the card.

5. Select File tab > Save Template.

Field Setting

Image Define the field name and select the format type of the graphic. 
Field Name: Enter Employee Photo
Format Type: .JPG
Select the Use a Folder Data Source option.

Folder Data 
Source

When the Use a Folder Data Source option is selected (in the step above), the Data Source pane 
in the top right, changes to the Folder Data Source.

Path: Select the path to where the photos are stored.
Key Field: Leave as Record ID (default). 

Note: Key fields are covered in Section 4 Data Entry application.

Options Select the Maintain Aspect Ratio option.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Do not select any options.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Black
Border Width: 2
Rounded Corners: 0
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3.2.7 Add a signature
Adding a signature can either be done through a graphic stored in a folder or through a signature capture 
device.

1. Select Card Design application > Home tab > Signature.

2. Click in the Card Display pane to open Signature Properties, set the following:

3. Click OK.

Field Setting

Image Define the field name and select the format type of the graphic. Do not select the options.
Field Name: Enter Employee Signature
Format Type: .JPG

Folder Data 
Source

The Table and Field options are disabled. A signature tablet is used to add the employee 
signature.

Options Select the Maintain Aspect Ratio option.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Do not select any options.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
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4. Position and size the signature field on the card.

5. Select File tab > Save Template.
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3.2.8 Add image (logo)
The image (such as a logo) displays on every card.

1. Select Card Design application > Home tab > Image.

2. Click in the Card Display pane to open Compound Field Properties, set the following:

3. Click OK.

Field Setting

Image Click Load new Image from file. Browse to locate the file.
The graphic appears in the Preview pane.
Note: If this is not the correct graphic or needs editing, select Edit Image.

Options Select the Maintain Aspect Ratio option.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Do not select any options.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0

Rounded 
Corners

Both options (Width and Height) should be left at 0.
38 September 2018



PLT-01485, Rev. 2.5 Card Design application
4. Position and size the image field on the card.

5. Select File tab > Save Template.

3.2.9 Background
A background displays on every card. This can be customized as a solid color, sample background or you can 
add your own background to the folder Asure ID > Images > Asure ID Backgrounds.

1. Select Card Design application > Home tab > Background.

Note: If the card is dual-sided, you can select which side to apply the background. You can also 
right-click on the card and select Add Background.
September 2018 39



Card Design application PLT-01485, Rev. 2.5
2. Select Add Background to Front of Card. 

3. Set the following on the Background Properties window:

4. In this example we select a color background. From the Select a Color option, click the Web tab. Select 
a color from the pull-down list. The color selection appears in the display window.

5. Click OK.

Field Setting

Image Click Load new Image from file. 
The graphic appears in the Preview pane.
Note: If this is not the correct graphic, or needs editing, select Edit Image.

Options Select the Maintain Aspect Ratio option.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Do not select any options.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0

Rounded 
Corners

Both options (Width and Height) should be left at 0.
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6. The background now displays on the card.

The basic card template is completed.

At this point you can edit any fields by double-clicking on the object and changing the properties in the 
dialog box.

Fields can also be freely moved by drag-and-drop or by changing the Placement properties window 
(displayed after double-clicking the object).

Resizing of an object can also be done by selecting and dragging by the handle to resize.

7. Select File tab > Save Template.

3.3 Advanced card design tutorial
Building upon the basic card template, you can add options such as:

Shapes - See the Card Design section in the Asure ID Reference Guide, Section 3 Card Design 
Application (PLT-01797), for information on adding shapes.

Barcode - See Section 3.3.1 Add a barcode

Magnetic Stripe - See Section 3.3.2 Magnetic stripe (magstripe)

Smart Chip - See Section 3.3.3 Enable smart chips

Note: For information on the PACS Registration, Laser Writer, or Live Link, see the Asure ID Reference 
Guide, Section 3 Card Design Application (PLT-01797).
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3.3.1 Add a barcode
Select Card Design application > Home tab > Image.

3.3.1.1  Barcode data tab
1. Click in the Card Display pane to open Barcode Properties set the following on the Data tab. 
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2. Click OK.

Field Setting

Barcode Field Name: Enter Barcode.
Type: Leave the default Code 39. There are many options available from the drop-down 
list. See the Asure ID Reference Guide, Section 3 Card Design Application 
(PLT-01797), for information.
Test String: Leave the test string.
Font: Arial
Font Size: 12
Rotate (CCW): 0
Maintain Aspect Ratio: Select this option. 

Create Fields Select Create a new Data Field. See Section 3.3.1.2 Create a barcode data field.

Select Fields Select the Barcode Data field from the Available 
pane, and click Add to move to the Active pane.
Note: This can only be done after the Barcode 

Data field has been created in the field 
above.

Quiet Zone Select the Include Quiet Zones option. This leaves a white area around the barcode for 
ease of reading.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Bar and Fill Color Select the following options as needed. In this example the following was set:
Bar Color: Black
Fill Color: Transparent

Printing Do not select any options.
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3.3.1.2  Create a barcode data field
1. Select Create a New Data Field. This is the information coded into the barcode. 

2. The Data Field Properties window opens.

3. Set the following on the Data Field Properties window.

Field Setting

Data Field Define the field name and enter the text to display in this field. 
Note: The Field Name should be a name that can be associated to the actual field text. 

Field Name: Enter Barcode Data
Field Type: Numeric
Field Options: Do not select any options.

Font Set the font options. In this example the following was set:
Font Name: Arial 
Color: Black
Font Height: 12
Font Style: No selection was made.

Alignment Select alignment options. In this example Both options were set as Center.

Options Do not select any options.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Select the Non-Printable Entry option.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
Fill Color: Transparent
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4. Click OK. You are returned to the Barcode Properties window, and this newly created field is listed on 
the Select Fields > Available pane.

3.3.1.3  Barcode options tab
1. Select the Show Barcode Text. option.

2. Click OK.

3. Position the barcode field on the card design area.

4. Select File tab > Save Template.
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3.3.2 Magnetic stripe (magstripe)
The Magstripe option is located on the Card Setup tab.

The magstripe is located on the back side of this card template. The default position is the top of the card.

To Add a Magstripe:

1. Select the Card Design application > Card Setup tab > Magstripe. 

2. On the Magstripe tab set the following:

3. On the Track 2 tab click Create a new Data Field.

Field Setting

Type Select the ISO option.

Options Select the Place Magstripe at card bottom.

Field Setting

Create Fields Click Create a new Data Field. See Section 3.3.2.1 Create a magstripe data field.

Select Fields Select the Magstripe Data field from the Available 
pane, and click Add to move to the Active pane.
Note: This can only be done after the Magstripe Data 

field has been created in the field above.
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3.3.2.1  Create a magstripe data field
1. Set the following on the Data Field Properties window.

2. Click OK. The magstripe is added to the bottom of the back of the card.

Field Setting

Data Field Field Name: Enter Magstripe Data
Field Type: Text
Field Options: This is a Unique Field

Font Set the font options. In this example the following was set:
Font Name: Arial 
Color: Black
Font Height: 10
Font Style: No selection was made.

Alignment Do not select any options.

Options Do not select any options.

Placement Leave whatever data is populated. The text box can be moved using drag/drop.

Printing Select the Non-Printable Entry option.

Border and 
Fill

Select the following options as needed. In this example the following was set:
Border Color: Transparent
Border Width: 0
Fill Color: Transparent
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3.3.3 Enable smart chips
Cards listed under the Enable Smart Chips option, have a smart chip embedded in the card. 

Note: The Smart Chip is not visible on the card template.

For enabling other types of smart chips other than what is shown in this example, see the Asure ID Reference 
Guide, Section 3 Card Design Application (PLT-01797).

The Card Properties pane shows any applications added. This section is only covering using iDIRECTOR® to 
enable an iCLASS® smart chip for a read application. 

To Enable a Smart Chip:

1. Select the Card Design application > Card Setup tab > Enable Smart Chips > IDirector > iCLASS.

2. The iCLASS Chip Properties dialog box opens. 

Field Setting

Configuration Card Type: Select the card type from the pull-down list. 
Note: If the reader is connected, select Auto Detect. For this example, leave the default 

(2K1).

Actions Click Add an Application.

Properties No settings for this option.
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3.3.3.1  iDIRECTOR wizard 
The iDIRECTOR® wizard allows you to add an iCLASS® application.

1. On the welcome window click Next.

2. Select the HID Access Control Application (Read) application. 

3. Click Next.

4. Select the H10301 (Std 26 Bit) Format Type.

Note: This configuration cannot be changed after the wizard is completed. If the application needs to 
be modified, you must delete the existing application, then add a new one.
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5. Click Next.

6. Select the Create a Data Field for each iDIRECTOR Field option for this example.

Create a Data Field for each iDIRECTOR Field option:

Disabled: To read HID Access Control Application information and write it to an external data 
source. 

Enabled: Asure ID creates a data field for the Facility Code and Card ID Number to be stored 
within the Asure ID native database.

7. Click Finish.
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8. A new tab with the new application is added. 
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9. The advanced card template is completed.
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4 Data Entry application

4.1 Data Entry overview
The Data Entry application allows you to populate the database created in Card Design with the appropriate 
data for the card, and print the designated cards. 

Note: The Asure ID® Solo edition is limited to 200 records. 

The Data Entry application has the following tabs, with a corresponding toolbar.

File: The File tab allows you quick access to open a template or data group, printing, encoding and 
Laser writer access.

Home: The Home tab allows the configuration of data input, photo and signature acquisition, and 
record finding/filtering options.

Database: This tab groups import/export and record archive, restore, refresh options.

View: This tab groups the views of current records and record layout options.

Advanced: This tab groups laser controls, encoding, and PACS Integration. 
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4.2 Data Entry Home tab
The Data Entry Home tab contains the basic tools to create a data field. See the Asure ID Reference Guide, 
Section 4 Data Entry Application (PLT-01797) for detailed information on these tools.

4.2.1 Add a record with data, photo, and image fields
Records can be added individually or in a batch. To add more than one record at a time, select Add Batch and 
input the number of records to add. The window displays these as blank records. 

Note: This option cannot be used if:

The data field is linked with Live Link.

There are mandatory entries on the template.

Add a Single Record:

1. Select the Data Entry application > Home tab > Add.
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2. A new, empty record is displayed. 

Note: The data fields that were added when designing the card template are listed on this new record, 
ready for the entering information. 

3. Enter the following information:

4. To add an Employee Photo:

a. Right-click on the Employee Photo area and select Load from File. 

Note: Alternatively you can select the Load from File option from the toolbar.

b. Browse and select the employee image file. 

c. Crop the photo as needed in the Edit Image window, and click OK.

Note: To re-open the Edit Image window, double-click on the image.

Field Information

Employee Number Enter JDoe 12.
Note: The red star indicates the field is required.

Employee Dept. Select Engineering from the pull-down list.

First Name Enter Jane.

Last Name Enter Doe.
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d. The Effects option opens a window that allows you to modify the image for best results.

5. To add an Employee Signature:

a. Right-click in the Employee_Signature area and select Capture Signature.

b. You need to use the signature pad for capturing the signature. 

c. Click OK.

6. Click Barcode Data and type 123456 into the text field. 

7. Click Magstripe Data and type 12345678 into the text field. 

Note: For Track 2 data requirements, see the Asure ID Reference Guide (PLT-01797).
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8. Click Save within the Records group. When the Save button is selected, the card previews in the 
Preview and Filter Manager pane. 

9. To see an enlarged version you can double-click on the preview.

When this card is viewed in the enlarged preview, it is noticeable that the alignment of fields is visually not 
the best. This is where using the edit tools in the card design comes in handy.

Editing can be done at this stage by returning to the Card Design application and moving fields into better 
positions. 

Note: The Facility_Code and Card_ID_Number cannot be edited.
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4.3 Data Entry Database tab
The following section covers the Data Entry application Database tab. For additional information on the 
database and records see the Asure ID Reference Guide, Section 5 Databases (PLT-01797).

4.3.1 Import/export
Record information can be Imported from a MS Access database, SQL Server database, Oracle database, 
Excel, or a comma-separated values (CSV) file.

Import record information from a CSV file

1. Select Data Entry application > Database tab > Import Wizard.

2. The Import/Restore Wizard opens. Click Next.

3. On the Choose Import Source window, select Comma Separated Values.
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4. Click Next.

5. On the CSV Import Source window set the following:

Click Browse to locate and select the database to be imported.

Select the Contains Header Row option, if this applies.

Specify the Delimiter in the file.

6. Click Next.
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Below is an example of the CSV file.

7. On the Field Links window, to map the data fields:

a. Select a Import Source Field, and then the corresponding Template Field to link.

b. Click Add.

8. Select a Field from the Field Links and click Mark Unique. A unique field separates each record so there 
are no duplicates.
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9. To import a image:

a. Select a Image Field.

b. Click Image File Import.

c. Click Browse to locate and select the image file to be imported.

d. Select the Column Containing File Reference option, if this applies.

e. Specify the image File Type.

Note: Importing an image file in this manner removes any preexisting photo links into the wizard. When 
importing a CSV source, photos need to be retrieved from an external folder.

10.Click Next on the Wizard Field Links page.

11. On the Import Options window, select the Update existing records and import new records option.

12. Click Next.

13. Click Begin Import to update existing records. 

Note: As the update is performed, the log is displayed in the window.
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14. Click Next when complete.

15. The import is complete. Click Finish.

Note: The Data Entry records are added/updated with these changes.
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4.4 Data Entry View tab
The Data Entry View tab, contains all the tools to customize the views, including customizing the record 
layout. For detailed information on the View tab, see the Asure ID Reference Guide, Section 4 Data Entry 
Application (PLT-01797)

Records can be viewed as a single/multiple view or in a table format.
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4.5 Data Entry Advanced tab
The Data Entry Advanced tab, contains the advanced options that may be installed on the printer. If the 
options are not installed they are grayed out. 

Advanced options are:

Laser Controls

Encoding

PACS Integration

For detailed information on these options see the Asure ID Reference Guide, Section 4 Data Entry Application 
(PLT-01797). 
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5 Reports Application
The Reports Application provides you with preformatted reports of application operation. Reports can also 
customize in terms of layout, columns, and filters, which can be saved for future use. 

5.1 User Reports
User List: This report contains all users, capabilities, and general information.

User Activity: This report contains all the detailed user activities. 

User Login: This report contains all user login activity.

5.2 Data Entry Reports
Note: Right-click on any column heading in a report, for additional Column options. for more options. 

Columns can be rearranged or removed as required. 

All Records for a Template: This report contains all records (and associated data fields) for a selected 
template.

Records with no Photos: This report contains all records (and associated data fields without photos) 
for a selected template. 

Unprinted Records: This report contains all records that have not been printed, for a selected template.

Voided Records: This report contains all voided records for a selected template. 

Template History: This report contains all user activity for all templates.

Print History Report: This report contains history of all reports printed.

5.3 Card Design Reports
Template List: This report lists all the current templates. 

Data Fields for Template: This report lists the data fields for a selected template. 
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5.4 Create a report 
The following is the general process for creating a report.

1. Select Reports application > Home tab > All Records for a Template.

2. Select a template to run the report on. 

Note: This option is only required when needing Record or data entry field information (i.e. Data Entry 
Reports, or Data Fields for Template report.

3. Click OK.

4. The report is displayed. This example is the All Records for a template. 
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5.5 Custom report
A custom report is any report that you have run, that you have changed the layout (columns, sorting, etc.) To 
be able to reuse this report configuration the file can be saved for future use. 

1. After the report has been modified, select Save Custom Report from the toolbar.

2. Name the report and select Create Private Report.

3. Click OK.

4. The saved report is displayed under the Custom Reports tab.
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5.6 Export reports
Reports can be exported in the following file types:

PDF

XLS

RTF

To export a report

1. One a report has been run. Select Export from the toolbar.

2. Name and save the file.

The following example is a user record report exported to XLS (Excel file).
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6 iCLASS SE Encoder application

6.1 Overview
The iCLASS SE® Encoder application is used to encode HID Prox® and read/write applications onto smart 
cards.

The following matrix illustrates the supported capabilities and card types.

* Only supported for SIO PACS Applications

6.1.1 Credential credit management
All transactions are enabled by credential credits. These are individual credits that are used with every 
transaction until there are none or until additional credits are ordered and applied to the encoder. For 
information about ordering credentials, see the HID Global Credential Programmer How to Order Guide, 
which can be found on www.hidglobal.com.

Program HID Access Control Application Custom Data

Standard PACS 
Application

SIO PACS 
Application

Supported Key Types Standard 
Application

SIO 
Application

Supported 
Key Types

HID Prox cards and 
fobs


N/A

N/A
N/A N/A N/A

iCLASS®  N/A Standard/Elite/Custom 

Coming Soon

iCLASS SR   Standard/Elite/Custom 

iCLASS SE N/A  Standard/Elite/Custom 

iCLASS Seos® N/A  Standard/Elite/Custom 

MIFARE Classic 
(not Indala Flexsmart)




Standard/Elite*/Custom
* 

MIFARE DESFire EV1 N/A  Standard/Elite*/Custom 
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6.2 iCLASS SE® Encoder application modules
The iCLASS SE Encoder application contains three modules. 

6.2.1 Work Order Manager module
The Work Order Manager module allows you to define and save an encoding profile for a credential 
deployment. Each Work Order defines the number of data fields encoded, as well as the data type and field 
size. These data fields are concatenated into a single data stream and encoded into an application, and are 
defined by the selected format.

A Work Order is comprised of one or many Work Instructions. A Work Instructions is a single command 
issued during work order execution. The single work instruction can either read or write to a specific memory 
location.

6.2.2 Key Management module
The Key Management module of the iCLASS SE Encoder allows you to view and manage the HID and Custom 
Keys. See the Asure ID Reference Guide, Section 7 iCLASS SE Encoder application (PLT-01797) module for 
information on creating custom keys.

Note: Standard Keys and Key Sets are pre-loaded with the Encoder Configuration Package included on the 
USB stick. 

6.2.3 Reader Configuration module
The Reader Configuration window is used to create the Reader Data configuration cards (for both keys and 
reader limited settings) The application allows you to change the keys or behavior of a Reader. 
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6.3 Set up the iCLASS SE encoder 

6.3.1 Load the configuration package
Initially you receive the Credential Credits and Keys either through a configuration package included on the 
USB stick or in an email. To upload this package:

1. Select iCLASS SE Encoder application > Work Order Manager module > File tab > Upload 
Configuration Package. 

2. Browse to locate the Configuration Package from HID.

3. Select the file and click Open.
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4. A confirmation message is displayed at the bottom of the window and the Credential Credits are 
displayed in the Configuration pane.

Note: Keys may also be loaded, depending on what was ordered.

6.3.2 Install format
The iCLASS SE Encoder includes a format interpreter capable of parsing all open and custom formats 
developed and maintained by HID Global.

Format fields are presented to you in the desktop UI for the purpose of assigning data to each field.

Formats must be ordered from Customer Service. Most formats are custom to a specific OEM or end user, and 
are not freely distributed.

The H10301 is the default format delivered with the application.

To use a format other than the provided default format.

1. Select iCLASS SE Encoder application > Work Order Manager module > File tab > Install Formats. 

2. Browse to locate the Format file from HID. Select the file and click Open.

3. After the format is successfully loaded, the new format is displayed as an option when creating a Work 
Order.
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6.3.3 Create a work order
A Work Order is comprised of one or many Work Instructions. A Work Instruction is a single command 
issued during work order execution. The single work instruction can either read or write to a specific memory 
location. 

See Section 6.4 Use case 1: deploy standard security credentials or Section 6.5 Use case 2: deploy HID Prox 
credentials for two common Use Case scenarios. For detail information on all Work Order configurations, see 
the Asure ID Reference Guide.

6.4 Use case 1: deploy standard security credentials
This use case addresses the deployment of the legacy HID Access Control Application on iCLASS credentials. 
This application is the predominant application in use in the market for the last decade. The use case also 
addresses the lesser used legacy HID MIFARE application.

Note: The procedures in this use case assume readers are already configured with standard security keys for 
iCLASS and MIFARE SIO and have the iCLASS and MIFARE SIO data model interpreters. 

Note: For more detailed information, see the Asure ID Reference Manual.

6.4.1 Create a work order to encode iCLASS credentials
Create a new work order for iCLASS credentials

Creating a new work order begins the definition of a work instruction through a technology specific wizard 
plugin exposing many user selectable options.

1. Select iCLASS SE Encoder application > Work Order Manager module > New.

2. Select the iCLASS plugin and click OK.
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3. The iCLASS Encoding wizard opens. Click Next.

4. Set the options on the Select data format page. This page shows options to set up the instruction. 

In this use case we are selecting:

Instruction Type: Write

Data Type: HID Access Application

Options: No selection

Credential Type: HID Access Application

Format: H10301 
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5. Set the options on the Define Format Parameters page.

This page exposes options to customize the selected format. In this use case we are seeing the details 
of the H10301 format, which is the open, 26-bit SIA Wiegand format. 

6. Set the options on the Memory Map Configuration page.

Field/Column Description

Name The name field displays the names of the format parameters as assigned by HID. It is 
strongly recommended to leave these names as they are.

Parameter Type This field identifies the rules regarding how the value of a parameter is derived. 
These are read from the format file and there is typically no need to change.

Static This parameter type means every encoded credential has the value of the Default 
Value field for that parameter.

Manual User Entry This parameter type starts with the value of the Default Value field and allows you 
to enter a new number.

Enforce Unique Numbers This field ensures that a number can never be repeated. For best practice, it is 
recommended to keep this checked for the Card ID Number.

Default Value This field only has meaning for the Static and Manual User Entry parameter types. 
Auto Increment parameter type uses the Auto Number Range field.

Increment Step This field determines the step for format parameters that are of the Auto Increment 
parameter type.

Auto Number Range This field shows the allowable numbers that can be encoded for Auto Increment 
parameter Types. In the case of the H10301 format, the Card ID Number is open and 
untracked. This means all numbers for that parameter (16-bit number) are available. 
However, all Corporate 1k, proprietary, and open-managed formats have a Card ID 
parameter with a number range set in the format file that is determined when 
ordering the format.
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This page shows options to set the memory configuration of the iCLASS card.

Typically, encoding of iCLASS credentials is done with pre-configured credentials from HID (2k, 16x2k, 
etc.). In which case, the Expected Card Type is Configured and there are no further selections to make. 

In some rare use cases, the encoder can be used to configure a virgin iCLASS credential. In this case the 
Expected Card Type is set to Unconfigured and the Card Configuration must be selected from the 
supported list and match the credential type used.

7. Set the options on the Key Selection page.

This page exposes options to select the media keys used to authenticate with the HID Application on 
the iCLASS credential. 

In this use case we are using Standard security media keys. Elite or Custom media keys (if they are 
loaded) are also selectable at this step. 

8. Finish the wizard and save the Work Order.
76 September 2018



PLT-01485, Rev. 2.5 iCLASS SE Encoder application
6.4.2 Encode iCLASS credentials
1. When the work instruction(s) are executed, a message displays at the window bottom, the credential 

serial number displays in the main pane, and a new record becomes available for execution.

2. Open the iCLASS work order to encode from. Select Open from the toolbar, and select the Work Order 
from the list.

The work order table view shows the first credential ready to be encoded with a Card ID Number value 
of 1 and a Facility Code of 1.

In this case, the selected format for the work order is H10301. The Facility Code is a static parameter 
and we set a default of 1 in the Work Instruction wizard. Every credential is encoded with the value of 1 
for this parameter. The Card ID Number is Auto Increment and increases by one every time a credential 
is encoded. 

3. Select the record and select Execute Selected from the toolbar.

4. A status window provides feedback on the progress of the encoding operation.
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5. After the encoding operation is complete, the work order table view is updated with the Card Serial 
Number and a new record is created with the next Card ID Number.
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6.4.3 Create a work order to encode MIFARE classic credentials
Create a new work order for MIFARE classic credentials

1. Select iCLASS SE Encoder application > Work Order Manager module > New.

2. Select the MIFARE Classic plugin and click OK.

Creating a new work order begins the definition of one work instruction through a technology specific 
wizard plugin exposing many user selectable options.

3. The MIFARE Classic Encoding wizard opens. Click Next.
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4. Set the options on the Select Data Format page.

This page exposes options to set up the instruction. In this use case we are selecting:

Instruction Type: Write

Data Type: HID Access Application

Options: No selection

Credential Type: HID Access Application 

Format: H10301 

5. Set the options on the Define Format Parameters page. See Section 6.4.1 Create a work order to 
encode iCLASS credentials, Step 5. 
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6. Click Next on the Key Selection page. 

Note: Sector number and keys used for authentication are fixed and not selectable.

7. Finish the wizard and save the instruction profile.

6.4.4 Encode MIFARE credentials
1. When the work instruction(s) are executed, a message displays at the window bottom, the card serial 

number displays in the main pane, and a new record becomes available for execution.

2. Open the MIFARE Classic work order to encode from. Select Open from the toolbar, and select the 
Work Order from the list.

The work order table view shows the first credential ready to be encoded with a Card ID Number value 
of 1 and a Facility Code of 1.

In this case, the selected format for the work order is H10301. The Facility Code is a static parameter 
and we set a default of 1 in the Work Instruction wizard. Every credential is encoded with the value of 1 
for this parameter. The Card ID Number is Auto Increment and increases by one every time a credential 
is encoded. Select the record and select Execute Selected from the toolbar.

3. A status window provides feedback on the progress of the encoding operation.
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4. After the encoding operation is complete, the work order table view is updated with the Card Serial 
Number and a new record is created with the next Card ID Number.
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6.5 Use case 2: deploy HID Prox credentials
This use case addresses the deployment of HID Prox cards and fobs. 

6.5.1 Create a work order to encode HID Prox credentials
1. Select iCLASS SE Encoder application > Work Order Manager module > New.

2. Select the Prox plugin and click OK.

Creating a new work order begins the definition of a work instruction through a technology specific 
wizard plugin exposing many user selectable options.
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3. The Prox Encoding wizard opens. Click Next.

4. Set the options on the Select Data Format page.

This page exposes options to set up the instruction. In this use case we are selecting the H10301 as the 
Format.

In this use case we are selecting:

Instruction Type: Write

Options: No selection

Format: H10301

5. Set the options on the Define Format Parameters page. See Section 6.4.1 Create a work order to 
encode iCLASS credentials, Step 5.
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This page exposes options to customize the selected format. In this use case we are seeing the details 
of the H10301 format, which is the open, 26-bit SIA Wiegand format.

6. Finish the wizard and save the instruction profile.
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6.5.2 Encode HID Prox credentials
1. Open the Prox work order to encode from. Select Open from the toolbar, and select the Work Order 

from the list.

The work order table view shows the first credential ready to be encoded with a Card ID Number value 
of 1 and a Facility Code of 1.

In this case, the selected format for the work order is H10301. The Facility Code is a static parameter and 
we set a default of 1 in the Work Instruction wizard. Every card is encoded with the value of 1 for this 
parameter. The Card ID Number is Auto Increment and increases by one every time a card is encoded. 

2. Select the record and select Execute Selected from the toolbar.

3. A status window provides feedback on the progress of the encoding operation.
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4. After the encoding operation is complete, the work order table view is updated with the Card Serial 
Number and a new record is created with the next Card ID Number.
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Section 7

7 Advanced application
The Advanced Application is used to manage Users and Laser Printer configurations.

Note: This section covers the basics of the User Config module. For detailed information on the entire 
Advanced Application, see the Asure ID Reference Guide.
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7.1 User config module
With the Data Entry application, the Asure ID admin user imports/enters the user information. The Advanced 
Application allows the Asure ID admin to manage these records.

See Section 4 Data Entry application for detailed information.

7.1.1 Add a user
1. Select the Advanced application > User Config module > Home tab > Add User.

2. Enter the user information in the blank record. 

Note: Fields become active when the cursor is passed over them. 

3. Select the options for this user to have access to. In this example Card Design, Card Printing, and 
Reports have been selected.

4. In the Data Entry drop-down list, select Read/Write Access (no PACS).

5. In the iCLASS SE drop-down list, select Operator.

6. Select Save Users from the toolbar. This saves all users that have been modified.
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7.1.2 Modify and save a user
1. Select the Advanced application > User Config module > Home tab.

2. Select and modify one or more users as needed.

3. Select Save Users from the toolbar. This saves all users that have been modified.

7.1.3 Remove a user
1. Select the Advanced application > User Config module > Home tab.

2. Select a user.

3. Select Remove User from the toolbar, and click Yes to confirm.
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7.1.4 Change a user password
1. Select a user record.

2. Select Change Password from the toolbar.

3. In the pop-up dialog box, type in the new password and confirm.

4. Click OK.

7.1.5 Add a user group
1. Select the Advanced application > User Config module > Home tab > Manage Group.

2. In the Manage Group window, select the Add User Group icon.

3. Enter the group information in the blank record. 

Note: The field becomes active when the cursor is passed over it.

4. Select the options for this group to have access to. In this example Card Design, Card Printing, and 
Reports are selected.

5. In the Data Entry drop-down list, select Read/Write Access (no PACS).

6. In the iCLASS SE drop-down list, select Operator.
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7. Select the Save icon. This saves the user group. 
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7.1.6 Delete a user group
1. Select the Advanced application > User Config module > Home tab > Manage Group.

2. In the Manage Group window, select the group to delete and select the Delete Group icon.

3. In the Warning pop-up dialog box, click Yes to delete the user group. 
94 September 2018



PLT-01485, Rev. 2.5 Advanced application
7.1.7 Assign a template to a group
1. Select the Advanced application > User Config module > Home tab > Assign Template to Group.

2. In the Assign Template To Group window, select the group to assign the template to. In this example, 
Operator PACS.

3. Select the template type to filter (card templates, work orders or all). In this example Asure ID Card 
Template is selected.

4. Click the arrow key to move the selected Available Template column to the Assign Template column. 
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